<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://sports.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="nfc east picks, dallas cowboys, washington football team, new york giants, philadelphia eagles" />
<meta name="keywords" content="nfc east picks, dallas cowboys, washington football team, new york giants, philadelphia eagles" />
<title>NFL Week 11 NFC East Preview: &#8216;Eagles Ready To Get First Win Of Season At Home&#8217; &#8211; CBS Local Sports</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<meta name="msvalidate.01" content="2A261E945956F7D48FDBD699B85CD611" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.mp.lura.live' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Local Sports &raquo; Feed" href="https://sports.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://sports.cbslocal.com/_static/??-eJytj00OAiEMhS8kNkZDcGE8CwN1JFNawk+8vsi4caWTuGr72u/lFR5JOeGKXKHeMWIBNxVF4ixBYEfNv6RS4CZSMe97u4OfIIwT+pVNGUms/w4nanPgAlF8o76xb4Net8PjQEXLdsY8bD4U1UMuVdKGl1aPFie2gRQFXv6fCqlPXMe/13g56KM+G3PS5gl12Z9s' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://sports.cbslocal.com/_static/??-eJy1U9tOwzAM/SGyUHVM4wHxLWliddmcixJ3Vf4et3SUAoIWwVt8OcfHl8g+Ch08gSdJJ3CQpW6ywKAVykwFYadzvpPfpVmvsTODK2cZVQuCwEVUtAI7QADZ6Sn/nB2xa63P0gXTIUfGBOGU56Jp5KISYb9Rcm/NLHmFig/9pt8oz6eQSIcby2xuKA+uAfOKH58CbSahFSkM7cY2uAurEcR1Ht4ibphaNgy8cJUmqVSm63DWf0acuVEwVk2bXRg85QJJILRKl3Vwjr23F6DVE+ctt0BvGx/ef3FwTqXLQDudc8CQ/oE3XCH1yX7xo1wnbmRnoKh4QdX9rh45JseAeXZP1aE+PB6PD1X9Am8UfD8=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type="text/javascript" src="https://sports.cbslocal.com/_static/??-eJy1UMsOwjAM+yG6iIemcUB8S+my0ZKmZWmH9veUiQO7DSROVhzbsQKPqEzghJwgXdGjgLmIomA0gWVDuS2UE4iBps4SVd5y5WQDa41ulSNS7i0L+NBmKhvdzuYCatx9Jiyi7xmH6Q2rRMrbftAJf+o0C5TXrHscXtELQpV7txTiV8/pMptkA8s/CiGViZOU3LM/bet9fWyaQ924J7E/uk0=" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.2' id='partner__video__anvato-js'></script>
<script type="text/javascript" src="https://sports.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILUKgqhwQ39KlUZcqbSeSst+nQly4sJtlP9uwbxO2alQNbKVCCrjoJA2DAFeUHoeVFUJcSflFc+E6Zz3Bv+Lgk7QlyCH5c/E0RqHDziY9cVUoLXYZyc4xkX0mvnJMPMr97C7u5v3V+fwGCyFU5Q==" ></script><link rel="https://api.w.org/" href="https://sports.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://sports.cbslocal.com/wp-json/wp/v2/posts/66081" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sports.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sports.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://bit.ly/3Fn1TyV' />
<link rel="alternate" type="application/json+oembed" href="https://sports.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsports.cbslocal.com%2F2021%2F11%2F17%2Fnfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://sports.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsports.cbslocal.com%2F2021%2F11%2F17%2Fnfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;" /><meta property="og:image" content="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/jalen-hurts-eagles-2-1.jpg?w=1200" /><meta property="og:image:secure_url" content="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/jalen-hurts-eagles-2-1.jpg?w=1200" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:description" content="CBS Philadelphia sports director Don Bell looks at the Cowboys-Chiefs, Saints-Eagles, Washington-Panthers, and Giants-Buccaneers matchups in Week 11." /><meta property="og:type" content="article" /><meta property="og:url" content="https://sports.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/" /><meta property="article:published_time" content="2021-11-17T13:54:08+00:00" /><meta property="article:suggested-social-copy" content="CBS Philadelphia sports director Don Bell looks at the Cowboys-Chiefs, Saints-Eagles, Washington-Panthers, and Giants-Buccaneers matchups in Week 11." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Sports" /><meta property="article:publisher" content="https://www.facebook.com/CBSLocalSports" /><meta property="article:author" content="https://www.facebook.com/CBSLocalSports" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/jalen-hurts-eagles-2-1.jpg?w=1200"><meta name="twitter:title" content="NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;"/><meta name="twitter:description" content="CBS Philadelphia sports director Don Bell looks at the Cowboys-Chiefs, Saints-Eagles, Washington-Panthers, and Giants-Buccaneers matchups in Week 11."/><meta name="twitter:site" content="/CBSLocalSports"/>
<link rel="canonical" href="https://philadelphia.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://sports.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/sports.cbslocal.com","url":"https:\/\/sports.cbslocal.com","name":"CBS Local Sports","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/sports.cbslocal.com\/wp-content\/uploads\/sites\/33383831\/2018\/11\/cbs-local-sport-color-horz-logo-1.png?w=420"}},"url":"https:\/\/sports.cbslocal.com\/2021\/11\/17\/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/sports.cbslocal.com\/2021\/11\/17\/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks\/"},"headline":"NFL Week 11 NFC East Preview: &#8216;Eagles Ready To Get First Win Of Season At Home&#8217;","description":"CBS Philadelphia sports director Don Bell looks at the Cowboys-Chiefs, Saints-Eagles, Washington-Panthers, and Giants-Buccaneers matchups in Week 11.","image":"https:\/\/sports.cbslocal.com\/wp-content\/uploads\/sites\/33383831\/2021\/11\/jalen-hurts-eagles-2-1.jpg?w=1200","keywords":["Sports","Don Bell","NFC East","NFL Expert Picks","Norm Elrod","sports","NFL Week 11 NFC East Preview: 'Eagles Ready To Get First Win Of Season At Home'"],"datePublished":"2021-11-17T13:54:08+00:00","dateModified":"2021-11-17T13:54:08+00:00","video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"NFC East Preview Week 11: Eagles, Hosting Saints, Look For First Home Win; Cowboys Meet Chiefs At Arrowhead","description":"CBS Philadelphia sports director Don Bell looks at Week 11 matchups in the NFC East. The Eagles, who look like they\u2019re about to turn a corner, face a Saints team that\u2019s lost two straight. The Cowboys and Chiefs meet up after dominant wins. Washington matches up with the revitalized Panthers. And the Giants draw the Buccaneers and an angry Tom Brady. Katie Johnston reports.","thumbnailUrl":"https:\/\/m101675-ucdn.mp.lura.live\/anv-iupl\/45E\/72C\/45E72C6D6F64212A64965FD85380CFEC.jpg?Expires=1731888000&KeyName=mcpkey1&Signature=hDLUdNW1H4YI61z8XPSZpPnGme0","uploadDate":"2021-11-17","duration":"T5M8S","contentUrl":"https:\/\/sports.cbslocal.com\/video\/6159985-nfc-east-preview-week-11-eagles-hosting-saints-look-for-first-home-win-cowboys-meet-chiefs-at-arrowhead\/","embedUrl":"https:\/\/sports.cbslocal.com\/video\/6159985-nfc-east-preview-week-11-eagles-hosting-saints-look-for-first-home-win-cowboys-meet-chiefs-at-arrowhead\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.FSL","sports",["nflweek11nfceastprevieweaglesreadytogetfirstwinofseasonathome","post","article","sports","donbell","nfceast","nflexpertpicks","normelrod","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"sports;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

		<style type="text/css" id="wp-custom-css">
			
.single-post sup {
	vertical-align: super;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="CBS Philadelphia sports director Don Bell looks at the Cowboys-Chiefs, Saints-Eagles, Washington-Panthers, and Giants-Buccaneers matchups in Week 11." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-66081 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://sports.cbslocal.com" id="header-logo"><img src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2018/11/cbs-local-sport-color-horz-logo-1.png?w=420" alt="CBS Local Sports" /></a>
	
	<nav id="navigation-main" data-item-count="3"><ul class="top"><li class="menu-top-item item-0 section-item w-link"><a href="https://sports.cbslocal.com" title="Home" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Home</strong></div></a></li><li class="menu-top-item item-1 w-link"><a href="https://sports.cbslocal.com/" title="Featured" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Featured</strong></div></a></li><li class="menu-top-item item-2 w-link"><a href="https://sports.cbslocal.com/category/voices/" title="Voices" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Voices</strong></div></a></li></ul></nav>
	
	
	<div id="info-search"><form action="https://sports.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">NFL Week 11 NFC East Preview: &#8216;Eagles Ready To Get First Win Of Season At Home&#8217;</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">November 17, 2021 at 1:54 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://sports.cbslocal.com/tag/don-bell/">Don Bell</a>, <a href="https://sports.cbslocal.com/tag/nfc-east/">NFC East</a>, <a href="https://sports.cbslocal.com/tag/nfl-expert-picks/">NFL Expert Picks</a>, <a href="https://sports.cbslocal.com/tag/norm-elrod/">Norm Elrod</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"6159985","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"sports.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"sports.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.FSL&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/bit.ly\/3Fn1TyV","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(<a href="https://philadelphia.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/" rel="nofollow">CBS Philadelphia</a>) &#8212;</strong> With the playoffs slowly approaching, the Dallas Cowboys are the NFC East&#8217;s only legitimate contender. After an ugly loss to the Denver Broncos two weeks ago, they pushed around the Atlanta Falcons in Week 10. The Eagles sit three wins back after taking care of the Broncos last week. The Washington Football team and New York Giants are also coming off of impressive wins. Washington took down the mighty Tampa Bay Buccaneers in what might become the highpoint of their season. Giants dispensed with the Las Vegas Raiders.</p>
<p>The Cowboys will have a much tougher time this week against a Kansas City Chiefs team that seems to have found its way. The Eagles host the New Orleans Saints, hoping to keep pace with the Cowboys. Washington heads to Carolina to meet the Panthers, who head coach Ron Rivera once led to the Super Bowl. And the Giants meet the Tampa Bay Buccaneers, who are still smarting from last week&#8217;s lost to Washington.</p>
<p>CBS Philadelphia sports director Don Bell breaks down the four NFC East matchups in Week 11.</p>
<p><em>All times listed are Eastern.</em></p>
<p><em><strong><a href="https://www.paramountplus.com/account/signup/live-tv/?intcid=CIA85fa358" target="_blank" rel="nofollow">Stream your local NFL On CBS game live on Paramount+.</a></strong></em></p>
<p><strong>Dallas Cowboys @ Kansas City Chiefs, Sunday, November 21 @ 4:25 p.m.&nbsp;</strong></p>
<p>The Cowboys-Chiefs matchup this Sunday could be a preview of this season&#8217;s Super Bowl. &#8220;I think this is the game of the week,&#8221; said Bell. &#8220;Because we saw Kansas City get right last week in Vegas. They were tremendous in doing so. And we saw the Cowboys, pretty angry about losing to the Denver Broncos a week before, so they come out, and they stomped down the Atlanta Falcons.&#8221;</p>
<p>The Cowboys, at 7-2, easily control the NFC East and are coming off of dominating 43-3 win over the Falcons. Dak Prescott threw for two touchdowns and almost 300 yards. The one-two rushing attack of Ezekiel Elliott and Tony Pollard combined for 83 yards and two more scores, though their sub-four-yard average left something to be desired. And the the defense stepped up again, with Trevon Diggs adding to more interceptions, including another pick-six.</p>
<p>The Chiefs sit at 6-4, and despite some struggles this season, are showing signs of rounding into form. The reigning AFC champions most recently thumped the Las Vegas Raiders, 4-14, to pull ahead by a win in the AFC West. Patrick Mahomes put up video game numbers, going 35-50 for 406 yards and five touchdowns. Travis Kelce and Darrel Williams both topped 100 yards receiving. Even their defense is showing some improvement.</p>
<p>And then there&#8217;s the coaching factor, and a glance at Andy Reid&#8217;s history suggests something is about to happen. &#8220;I have a sneaking suspicion that the Chiefs are about to make that run,&#8221; Bell revealed. &#8220;If you&#8217;re familiar with Andy Reid&#8217;s record &#8212; and I am, having lived in Philadelphia forever and watching him with the Eagles before he went to Kansas City &#8212; this is the time of year when he tends to make hay, when things start to go right for his football team. November and December is when they get right. The defense is playing better. I like the Chiefs in this game to beat the Cowboys in KC.&#8221;</p>
<p><strong>New Orleans Saints @ Philadelphia Eagles, Sunday, November 21 @ 1:00 p.m.&nbsp;</strong></p>
<p>The Eagles have a lot of work to do if they&#8217;re going to catch the Cowboys or sneak into the wild card discussion. While they&#8217;re in second place in the NFC East, their 4-6 record suggests that&#8217;s more a function of the quality of teams in the division. Still Philadelphia has shown growth in recent weeks. After putting down the Detroit Lions, 44-6, they played the Los Angeles Chargers tough in a losing effort and dispensed with the Broncos.</p>
<p>&#8220;They&#8217;ve played their best football over the last three weeks,&#8221; Bell noted. &#8220;They&#8217;re coming off a huge win in Denver. Jalen Hurts is starting to assert himself in the passing game. The thing to look for in this game is the fact that the Saints have the number one rushing defense. The Eagles are third in the NFL running the ball but number one since Week 8, rushing for over 200 yards per contest. This going to be a really good game down at The Linc.&#8221;</p>
<p>Part of the Eagles&#8217; success on the ground should be credited to Hurts. The dual-threat quarterback topped 50 yards rushing in each of his last three games, and in most games this season. His average per carry was down against the Broncos, however. And the Eagles may have to rely more on the pass against a tough Saints run defense. Hurts went 16-23 for 178 yards, two touchdowns and an interception against Denver. Those stats don&#8217;t put him anywhere close to the NFL&#8217;s elite passers, but they do show progress.</p>
<p>The Saints are dealing with transition at quarterback as well. Jameis Winston&#8217;s knee injury a few weeks ago required surgery, which ended his season. Trevor Siemian is the starter now, and he&#8217;s had some success running the offense. He went 25-41 for 249 yards and two TDs against the Falcons and 19-34 for 298 yards and two TDs against the Tennessee Titans. Neither performance led to a win.</p>
<p>&#8220;Sean Payton, to me, is one of the best coaches really to ever do it,&#8221; Bell said. &#8220;He&#8217;s going to go straight to the Hall of Fame, whenever he&#8217;s eligible to go there. He knows how to get his quarterbacks ready to play. Trevor Siemian obviously is the guy now. But listen, they&#8217;ve lost two in a row, and the Saints are having some issues now.&#8221;</p>
<p><strong>Washington Football Team @ Carolina Panthers, Sunday, November 21 @ 1:00 p.m.&nbsp;</strong></p>
<p>It&#8217;s been a disappointing season for the Washington Football Team so far. After winning the NFC East last season, Washington sits in the division cellar at 3-6. Their highly touted defense has become one of the league&#8217;s worst. And an offense run by backup journeyman Taylor Heinicke has found it difficult to close out games. But in Week 10, somehow it all worked.</p>
<p>&#8220;Sometimes we&#8217;re really dramatic when we follow football,&#8221; Bell noted. Like Washington beating the Bucs last week, to me, may be the win of the year in the NFL. And I know that sounds really dramatic. But no one saw that coming, especially because the Bucs were coming off a loss. But Washington able to get it done and able to hold down Tom Brady.&#8221;</p>
<p>In Week 11, the WFT will face the Carolina Panthers, another team that has had its struggles. Their offense is built to rely on running back Christian McCaffrey. But McCaffrey has struggled with injuries this season, and quarterback <a href="https://www.cbssports.com/fantasy/football/news/panthers-sam-darnold-likely-done-for-2021/" target="_blank" rel="nofollow">Sam Darnold</a> proved unable to carry more of the load. The offense only puts up 320.9 yards per game, among the worst in the league. A shoulder injury recently forced Darnold onto injured reserve. And it opened the door for the return of longtime Panther QB Cam Newton.</p>
<p>&#8220;I think that Cam Newton swag is real,&#8221; said Bell. &#8220;I think that he is energized by being back in the league. As he said in the postgame press conference, this time last week I was sitting on the couch eating a bowl of cereal. This time he&#8217;s ready to ball. I like the Panthers.&#8221;</p>
<p>Newton saw limited action in his first game back. But he did find the end zone in their 34-10 win over the Arizona Cardinals. Newton could take over for Phillip Walker once he&#8217;s up to speed. And with a healthy McCaffrey and a strong defense, the Panthers could get their season going in the right direction.</p>
<p><b>New York Giants @ Tampa Bay Buccaneers, Sunday, November 21 @ 8:20 p.m.&nbsp;</b></p>
<p>The Giants are coming off a 23-16 win over the Las Vegas Raiders. Daniel Jones only threw for 110 yards and a touchdown. But Devontae Booker ran for 99 yards on 21 carries. Booker is nursing a hip injury that doesn&#8217;t appear likely to keep him out of action on Monday night. But the Giants have bigger concerns.</p>
<p>They will be facing Tom Brady and the Buccaneers, who are coming off their second-straight loss. The underperforming Washington defense held them in check for much of the afternoon. Brady only went 23-34 for 220 yards and two touchdowns. He was picked off twice. The Bucs defense largely limited a mediocre offense led by Taylor Heinicke, as one might expect. But in the fourth quarter, when they needed to put the ball back in Brady&#8217;s hands, they couldn&#8217;t. Heinicke led the WFT offense on an 80-yard drive, lasting 19 plays and taking over 10 minutes off the clock. The drive resulted in a touchdown and essentially ended the game.</p>
<p>The Giants will face an angry Bucs team looking to reassert itself. &#8220;We like to say &#8216;any given Sunday,'&#8221; according to Bell. &#8220;So, yeah, they have a chance. But who&#8217;s out here ready to bet on Brady losing three straight? I just don&#8217;t see it, especially at home. Tom Brady&#8217;s going to have that face that he wears, where it&#8217;s like his cheekbones are really chiseled and he&#8217;s staring through your soul. I like the Buccaneers in this game. I don&#8217;t see any possible way that they lose three in a row.&#8221;</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://bit.ly/3Fn1TyV"></a><a class="addthis_button_twitter"  addthis:url="https://bit.ly/3Fn1TyV"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://bit.ly/3Fn1TyV"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSLocalSports" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CBSLocalSports" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://www.youtube.com/CBSLocalSports" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://sports.cbslocal.com/2015/08/30/twitterverse-best-of-sarkafterdark/" title="Twitterverse Best Of: #SarkAfterDark" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/08/gettyimages-459435490.jpg?resize=55%2C55&#038;ssl=1" alt="Twitterverse Best Of: #SarkAfterDark" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/08/30/twitterverse-best-of-sarkafterdark/" title="Twitterverse Best Of: #SarkAfterDark" class="bump-view" data-bump-view="tp">Twitterverse Best Of: #SarkAfterDark</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2021/11/17/college-football-preview-arkansas-alabama-san-diego-state-unlv/" title="&#039;Arkansas Has No Fear Of Alabama&#039;: CBS Sports’ Kevin Carter Previews College Football Matchups" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/kj-jefferson-arkansas-1.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Arkansas Has No Fear Of Alabama&#039;: CBS Sports’ Kevin Carter Previews College Football Matchups" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2021/11/17/college-football-preview-arkansas-alabama-san-diego-state-unlv/" title="&#039;Arkansas Has No Fear Of Alabama&#039;: CBS Sports’ Kevin Carter Previews College Football Matchups" class="bump-view" data-bump-view="tp">&#039;Arkansas Has No Fear Of Alabama&#039;: CBS Sports’ Kevin Carter Previews College Football Matchups</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/" title="NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;" class="bump-view" data-bump-view="tp" aria-current="page">
								<img width="55" height="55" src="https://i2.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/jalen-hurts-eagles-2-1.jpg?resize=55%2C55&#038;ssl=1" alt="NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2021/11/17/nfc-east-cowboys-giants-eagles-washington-nfl-week-11-picks/" title="NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;" class="bump-view" data-bump-view="tp" aria-current="page">NFL Week 11 NFC East Preview: &#039;Eagles Ready To Get First Win Of Season At Home&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2015/06/09/steroids-allowed-sports/" title="Lemco: Why Steroids Should Be Allowed In Sports" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/06/arod-e1433880094836.jpg?resize=55%2C55&#038;ssl=1" alt="Lemco: Why Steroids Should Be Allowed In Sports" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/06/09/steroids-allowed-sports/" title="Lemco: Why Steroids Should Be Allowed In Sports" class="bump-view" data-bump-view="tp">Lemco: Why Steroids Should Be Allowed In Sports</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2015/12/04/detroit-lions-matt-stafford-wife-speak-her-mind/" title="Matt Stafford&#039;s Wife Isn&#039;t Afraid To Speak Her Mind" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/12/gettyimages-142155140.jpg?resize=55%2C55&#038;ssl=1" alt="Matt Stafford&#039;s Wife Isn&#039;t Afraid To Speak Her Mind" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/12/04/detroit-lions-matt-stafford-wife-speak-her-mind/" title="Matt Stafford&#039;s Wife Isn&#039;t Afraid To Speak Her Mind" class="bump-view" data-bump-view="tp">Matt Stafford&#039;s Wife Isn&#039;t Afraid To Speak Her Mind</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2015/07/03/lemco-why-football-needs-less-pads/" title="Lemco: Why Football Needs Less Pads" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/07/gettyimages-464544724.jpg?resize=55%2C55&#038;ssl=1" alt="Lemco: Why Football Needs Less Pads" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/07/03/lemco-why-football-needs-less-pads/" title="Lemco: Why Football Needs Less Pads" class="bump-view" data-bump-view="tp">Lemco: Why Football Needs Less Pads</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2015/06/16/athletes-money-contracts/" title="Lemco: Why Pro Athletes Deserve The Money They Make" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/06/gettyimages-475759640.jpg?resize=55%2C55&#038;ssl=1" alt="Lemco: Why Pro Athletes Deserve The Money They Make" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/06/16/athletes-money-contracts/" title="Lemco: Why Pro Athletes Deserve The Money They Make" class="bump-view" data-bump-view="tp">Lemco: Why Pro Athletes Deserve The Money They Make</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2015/05/21/lemco-why-soccer-sucks-and-is-also-bad-and-stupid/" title="Lemco: Why Soccer Sucks And Is Also Bad And Stupid" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2015/05/467174410.jpg?resize=55%2C55&#038;ssl=1" alt="Lemco: Why Soccer Sucks And Is Also Bad And Stupid" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2015/05/21/lemco-why-soccer-sucks-and-is-also-bad-and-stupid/" title="Lemco: Why Soccer Sucks And Is Also Bad And Stupid" class="bump-view" data-bump-view="tp">Lemco: Why Soccer Sucks And Is Also Bad And Stupid</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2021/11/03/nwsl-playoffs-carli-lloyd-red-stars-gotham-fc-spirit-courage/" title="NWSL Playoffs Start Sunday; Carli Lloyd Possibly Playing In Last Match" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/11/carli-lloyd-gotham-fc-1.jpg?resize=55%2C55&#038;ssl=1" alt="NWSL Playoffs Start Sunday; Carli Lloyd Possibly Playing In Last Match" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2021/11/03/nwsl-playoffs-carli-lloyd-red-stars-gotham-fc-spirit-courage/" title="NWSL Playoffs Start Sunday; Carli Lloyd Possibly Playing In Last Match" class="bump-view" data-bump-view="tp">NWSL Playoffs Start Sunday; Carli Lloyd Possibly Playing In Last Match</a>
							</div>
													</li>
										<li>
						<a href="https://sports.cbslocal.com/2021/10/27/college-football-preview-georgia-florida-san-diego-state-fresno-state/" title="The Aztecs &#039;Slowly Crush You&#039;: CBS Sports&#039; Randy Cross Previews Fresno State-#21 San Diego State, Other Matchups" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/sports.cbslocal.com/wp-content/uploads/sites/33383831/2021/10/jordon-brockshire-san-diego-state-1.jpg?resize=55%2C55&#038;ssl=1" alt="The Aztecs &#039;Slowly Crush You&#039;: CBS Sports&#039; Randy Cross Previews Fresno State-#21 San Diego State, Other Matchups" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://sports.cbslocal.com/2021/10/27/college-football-preview-georgia-florida-san-diego-state-fresno-state/" title="The Aztecs &#039;Slowly Crush You&#039;: CBS Sports&#039; Randy Cross Previews Fresno State-#21 San Diego State, Other Matchups" class="bump-view" data-bump-view="tp">The Aztecs &#039;Slowly Crush You&#039;: CBS Sports&#039; Randy Cross Previews Fresno State-#21 San Diego State, Other Matchups</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-horizontal">
			<section class="top"><div class="wrapper">
			<a href="https://sports.cbslocal.com" class="logo"><img src="https://sports.cbslocal.com/wp-content/uploads/sites/33383831/2018/11/cbs-local-sport-color-horz-logo.png" alt="CBS Local Sports" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSLocalSports" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CBSLocalSports" class="twitter" target="_blank">Twitter</a><a href="http://www.youtube.com/CBSLocalSports" class="youtube" target="_blank">YouTube</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			<div id="block-0" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">By Market</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="http://atlanta.cbslocal.com/category/sports/" target="_blank" title="Atlanta" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Atlanta</strong></div></a><a href="http://baltimore.cbslocal.com/category/sports" target="_blank" title="Baltimore" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Baltimore</strong></div></a><a href="http://boston.cbslocal.com/category/sports" target="_blank" title="Boston" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Boston</strong></div></a><a href="http://chicago.cbslocal.com/category/sports" target="_blank" title="Chicago" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Chicago</strong></div></a><a href="http://cleveland.cbslocal.com/category/sports" target="_blank" title="Cleveland" class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Cleveland</strong></div></a><a href="http://connecticut.cbslocal.com/category/sports/" target="_blank" title="Connecticut" class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Connecticut</strong></div></a><a href="http://dallas.cbslocal.com/category/sports" target="_blank" title="Dallas" class="cbs-thumbnail-link item-6" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Dallas</strong></div></a><a href="http://denver.cbslocal.com/category/sports/" target="_blank" title="Denver" class="cbs-thumbnail-link item-7" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Denver</strong></div></a><a href="http://detroit.cbslocal.com/category/sports" target="_blank" title="Detroit" class="cbs-thumbnail-link item-8" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Detroit</strong></div></a><a href="http://houston.cbslocal.com/category/sports" target="_blank" title="Houston" class="cbs-thumbnail-link item-9" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Houston</strong></div></a><a href="http://lasvegas.cbslocal.com/category/sports/" target="_blank" title="Las Vegas" class="cbs-thumbnail-link item-10" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Las Vegas</strong></div></a><a href="http://losangeles.cbslocal.com/category/sports/" target="_blank" title="Los Angeles" class="cbs-thumbnail-link item-11" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Los Angeles</strong></div></a><a href="http://miami.cbslocal.com/category/sports/" target="_blank" title="Miami" class="cbs-thumbnail-link item-12" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Miami</strong></div></a><a href="http://minnesota.cbslocal.com/category/sports/" target="_blank" title="Minnesota" class="cbs-thumbnail-link item-13" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Minnesota</strong></div></a><a href="http://newyork.cbslocal.com/category/sports" target="_blank" title="New York" class="cbs-thumbnail-link item-14" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">New York</strong></div></a><a href="http://philadelphia.cbslocal.com/category/sports" target="_blank" title="Philadelphia" class="cbs-thumbnail-link item-15" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Philadelphia</strong></div></a><a href="http://pittsburgh.cbslocal.com/category/sports" target="_blank" title="Pittsburgh" class="cbs-thumbnail-link item-16" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Pittsburgh</strong></div></a><a href="http://sacramento.cbslocal.com/category/sports" target="_blank" title="Sacramento" class="cbs-thumbnail-link item-17" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Sacramento</strong></div></a><a href="http://sanfrancisco.cbslocal.com/category/sports/" target="_blank" title="San Francisco" class="cbs-thumbnail-link item-18" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">San Francisco</strong></div></a><a href="http://seattle.cbslocal.com/category/sports/" target="_blank" title="Seattle" class="cbs-thumbnail-link item-19" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Seattle</strong></div></a><a href="http://stlouis.cbslocal.com/category/sports/" target="_blank" title="St. Louis" class="cbs-thumbnail-link item-20" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">St. Louis</strong></div></a><a href="http://washington.cbslocal.com/category/sports" target="_blank" title="Washington" class="cbs-thumbnail-link item-21" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Washington</strong></div></a></div>
</div></div>		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://sports.cbslocal.com" class="logo"><img src="https://sports.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Local Sports" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=sports.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10"><a href="https://www.viacomcbsprivacy.com/policy">Privacy Policy</a></li>
<li id="menu-item-58173" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-58173"><a href="https://www.viacomcbsprivacy.com/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-64580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64580"><a href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://sports.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1636988468g' type='text/css' media='all' />
<link rel='stylesheet' id='screen-css-0' href='https://sports.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/UB9uQWJyWBz7HNtDc2MzSwtLEzMLAAafzW7' type='text/css' media='screen' />
<script type="text/javascript" src="https://sports.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1636569970g" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202146.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'162246222',post:'66081',tz:'-5',srv:'sports.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246222', '66081' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":172,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>